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[Failed order] The offer xxx-xxxx-xxxx-xxxx is not purchasable - Item xxxx-xxxx-xxxx is not purchasable

Modified on: Fri, 17 Nov 2023 10:39 AM
Original Publishing Date:
2023-08-22

Symptoms


Sales order failed with following error:


The order provisioning failed.
The last error is "Service Creation Failed: Task "Provisioning "subscriptionService" for APS application CSP Microsoft 365 Nonprofit(https://aps.connect.cloudblue.com/connector)" (id = 320396) is failed with error: "'409 Conflict' received from 'POST https://aps.connect.cloudblue.com/connector/tenant':
The purchase request PR-1234-567-891 has not been completed.
The vendor has rejected the request with following reason:
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Message from the Vendor: The offer xxxx-xxx-xxxx-xxxx is not purchasable - Item xxxx-xxx-xxxx-xxxx is not purchasable.
Null


Cause

The issue can be happened due to  Offer specified is not available for purchase. Most likely it was retired by Microsoft and no longer available for sale.


Resolution


1. Make sure that the offer is no longer provided by Microsoft. For instance, retired offers are absent in Microsoft offer matrix (it can be obtained in Partner Center).


2. Please check the PR status in connect .If it is failed with the same error , Cancel current sales order.


3. Edit each Service Plan Publication Settings to remove from the Store and the Control Panel (Uncheck the Published attribute)


4. Edit each Service Plan Renewal settings to prohibit the renewals:

    4.1. Set the Auto-renewal to “Disabled”

    4.2. Deactivate each Subscription Period in the plan


5. Apply these changes to the Delegated Plans (Synchronize the Reseller plan(s) to the Resellers)