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[PLM] Subscription keeps disabled on OA after cancel failed Cancellation Order

Modified on: Thu, 29 Feb 2024 12:22 PM

Symptoms


Customer has placed a Cancellation Order (CL) for a PLM subscription, but this CL is failed or rejected on Connect and manually cancelled on CBC. However, this subscription keeps in "disabled" status on the OA side even if it is back to "active" on BA.


Cause


CF order failed on stopping of the subscription. In this case if stopping of the subscription fails then the subscription is not stopped. And on the cancellation of CF order it will not be started due to it has not been stopped on CF order placement due to error. The pem.revertToSubscriptionStateSnapshot() openapi method is not called on the cancellation of the CF order. 


This issue is caused by software issue #OA-38609.


Resolution


There is an available w/a.


In case of failed tasks stuck on the task manager queue after CL cancelled, also need to cancel. Once subscription queue is clean on task manager, enable subscription manually with pem.enableSubscription method:

https://docs.cloudblue.com/cbc/20.4/premium/content/Operations-Public-API-Reference/pem.enableSubscription.htm