CBC License expires too soon
Modified on: Sat, 2 Dec 2023 5:55 PMSymptoms
The license should have been updated with an expiration date of 1 year from now.
Cause
The license expiry date shown in the control panel (PCP > System > Information > PRODUCT LICENSE tab) is usually different from the real expiration date on our licensing server.
License in the platform is automatically updated every month, at least 2 weeks in advance, and the expiration date is shifted by 1 month during the process, until it reaches the real expiration date.
Resolution
If the expiry date shown in CP is more than 2 weeks from the current date, there is no need to worry or do anything.
Only if it is less than 2 weeks from now, or if you want to verify that automatic license updates will not fail when the time comes, you may do the following:
1. Verify that the license installed on your platform is not trial, but a permanent one.
Trial licenses usually end with ".0000", while permanent ones have some non-zero number at the end, e.g. ".0073".
If in doubt, you may ask your TAM to verify it.
2. Verify that "License update" periodic task is not failing in oss:
3. Verify the connectivity between your oss pod (or OA MN/osscore server for version 20.5) and our licensing server.
Example commands with "good" output:
To enter the pod:
To check the connectivity: