Azure NCE provisioning failed
Modified on: Fri, 17 Nov 2023 1:14 PM2023-08-03
Symptoms
Placed Sales Order for Azure NCE fails with following error:
In Azure NCE endpoint log we can observe similar error after retrieve subscriptions list information from Microsoft Partner Center:
Cause
The issue is on the CB Commerce Azure NCE APS connector. When retrieving subscriptions status it is received an unexpected status that is not one of the expected values included into following list: [none, deleted, suspended, active].
Resolution
The development of Azure NCE APS application has stopped and reached EOL as mentioned in https://docs.cloudblue.com/cbc/services/azure/home.htm, it is replaced by NCE Azure Connect connector.
This order can not be completed and must be switched to the new NCE Azure Connect connector.