[Rating Engine] Downgrade order did not have Refund Adjustment
Modified on: Fri, 17 Nov 2023 1:13 PM2023-02-20
Symptoms
'No Refund' refund policy was set in Subscription Period, however, when a downgrade order was placed, order was charged with prorated refund and no refund adjustment details created.
Cause
When a resource is downgraded to 0, it is considered by Rating Engine as resource cancellation - this is the behavior by design. This behavior is also applied during plan switch if the new plan does not contain the same resource.
If a resource is downgraded to 0, then the 'No Refund' policy from Subscription Period will be applied to it and refund adjustment details will be created.
However, if a resource was not downgraded to 0 (for eg: from 9 resources, downgrade to 3), it is considered as a normal change action therefore the refund policy will be taken from the settings in Advanced Billing Terms.
As an additional note, generally Rating Engine takes cancellation policy from Subscription Period, but for NCE subscription, Rating Engine takes policy from product catalog, where plan is deployed by PLM.
Resolution
In case no refund is the desired behavior for downsizing, please use the option 'Old amount' in Advanced Billing Terms settings.