[BA][TAX] Unable to place an order in UX1 due to "Plug-in is not configured."
Modified on: Fri, 17 Nov 2023 1:13 PM2022-08-09
Symptoms
Upon placement of order in UX1, the error "Unable to complete the operation, please cancel and try again later" will be prompted to the user.
The error we can observe via browser inspect can be seen as per below :
Cause
The root cause can be identified by investigating billing.log where the Exception message can be seen with identical error message - "Plug-in is not configured" :
The exception error can be seen to be triggered by Tax calculation for sales order and the method VERTEX::CalculateTaxes
Resolution
It is required to investigate vertex settings of the customer's Reseller in Billing > Settings > Taxation > Vertex > General.
If the reseller is configured to use vendor vertex settings, it is required to match the vertex configuration of Reseller's Provider inclusive of the Company Code.
In example : If Reseller L2 configuration Company Code is empty while Reseller's Provider which in this case is L1 have Company Code 9999, the error "Plug-in is not configured" can be triggered.
Reseller L2
L2's Provider (Which is Reseller L1)
Note : It is recommended to also check L1's configuration to match Provider(L0)