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CBC License expires too soon

Modified on: Sat, 2 Dec 2023 5:45 PM

Original Publishing Date: 

2023-11-14


Symptoms


We have a problem with our CloudBlue license expiry date on our platform. Although it was updated this month, the expiration date is shown to be next month.

The license should have been updated with an expiration date of 1 year from now.


Cause


The license expiry date shown in the control panel (PCP > System > Information > PRODUCT LICENSE tab) is usually different from the real expiration date on our licensing server.

License in the platform is automatically updated every month, at least 2 weeks in advance, and the expiration date is shifted by 1 month during the process, until it reaches the real expiration date.


Resolution


If the expiry date shown in CP is more than 2 weeks from the current date, there is no need to worry or do anything.


If it is less, or if you want to verify that automatic license updates will not fail when the time comes, you may do the following:


1. Verify that the license installed on your platform is not trial, but a permanent one. 

Trial licenses usually end with ".0000", while permanent ones have some non-zero number at the end. 

If in doubt, you may ask your TAM to verify it.


2. Verify that "License update" periodic task is not failing in oss:




3. Verify the connectivity between your oss pod (or OA MN/osscore server for version 20.5) and our licensing server.


Example commands with "good" output:


To enter the pod:

[root@linjmpb ~]# kubectl exec -ti oss-node-0 -- bash
Defaulted container "core-ear" out of: core-ear, conf (init)
[root@oss-node-0 /]# 
Generic


To check the connectivity:

[root@oss-node-0 /]# nc -w 2 -v keys.odin.com 5224 </dev/null
Ncat: Version 7.70 ( https://nmap.org/ncat )
Ncat: Connected to 52.29.203.196:5224.
Ncat: 0 bytes sent, 0 bytes received in 0.14 seconds.
[root@oss-node-0 /]#
Generic