Subscription renewed for 1 Month in CBC but for 1 Year in MSFT
Modified on: Mon, 4 Mar 2024 11:12 AMSymptoms
A customer purchases a 1 Year(s) subscription. A year later the subscription was about to expire when it was renewed, according to the subscription's autorenewal configuration, for 1 Month(s). As expected, in Commerce, the subscription period changed to 1 Month.
The issue is that when the subscription was renewed in MSFT it was renewed for 1 Year(s) not for a month, leading to a misalignment with CBC.
In the oss logs it can be seen that oss received openapi call to renew subscription:
There is also an event in PLM from oss with parameters={orderId=<order_id>, newPeriod={period=1, periodType=Month(s)}, currentPeriod={period=1, periodType=Year(s)}, startDate=<start_date>, expirationDate=<expiration_date>}}:
Cause
The issue is caused by an Invalid configuration in PPR. Subscription auto-renew to a different period scenario is not supported for the switch to the same plan. By default, all renewal operations for connect products will be processed instantly by PLM without sending any request to the Connect system.
Resolution
Autorenew switch to a period and a different plan was implemented in the scope of PFR-3132 (change order is created in that case).
To align the subscription between platforms, it will have to be terminated in offline mode and re-imported.