BSS call fails with AccessDenied when PPR is uploaded for reseller
Symptoms
Level 1 reseller who has an in-house products plan purchased under their account tries to upload new PPR file and gets an error:
{
"error": "com.ingrammicro.imcp.library.aps.exception.APSError",
"packageId": "d07c417e-9a8d-471e-bd98-5201f804e621",
"message": "Validation 'Sales categories without plans' failed with an unexpected error. Check logs.",
"http_request": "POST https://inhouse-products:8081/rest/application/23c7dca5-158e-4727-b792-07c47d341a8f/parseConfig"
}
SalesCategoryDetailedListGet_API will fail with access denied exception:
24-01-05 10:22:14.668 billing RQ5100438 TH00057 TRC] [xmlrpc_57_Execute_1704450134.666733] TRACE START SalesCategoryDetailedListGet_API
[24-01-05 10:22:14.668 BM_Object RQ5100438 TH00057 NTE] Entering method BM.SalesCategoryDetailedListGet_API(user = 1, SID = 0, lang = en, request
= 5100438, localObject = 0, transaction = 7376269 (HP))
[24-01-05 10:22:14.668 BM_Object RQ5100438 TH00057 NTE] 2 input arguments [int32_t: 1002412, int32_t: Int32(NULL)]
[24-01-05 10:22:14.668 BM_Object RQ5100438 TH00057 TRC] +++[0] ListResult* BM::SalesCategoryDetailedListGet_API(Int, Int)(1002412)
[24-01-05 10:22:14.671 BM_Object RQ5100438 TH00057 TRC] ...[0] *** INTERRUPTED BY EXCEPTION *** ListResult* BM::SalesCategoryDetailedListGet_API(I
nt, Int)
[24-01-05 10:22:14.671 BM_Object RQ5100438 TH00057 NTE] Finished method BM.SalesCategoryDetailedListGet_API(user = 1, SID = 0, lang = en, request
= 5100438, localObject = 0, transaction = 7376269 (HP))
[24-01-05 10:22:14.671 BM_Object RQ5100438 TH00057 NTE] ExceptionResult: Access Denied.
SalesCategoryDetailedListGet_API call made during PPR upload accepts accountId as an argument. Current implementation passes memberId instead of accountId. If there is no accountId equal to the memberId passed as the argument, the call fails with AccessDenied exception.
The issue has been identified in PLM version: inhouse-products 2.0-1019
Cause
The case has been analyzed further and submitted to CloudBlue Automation R&D Team as an internal issue with ID PDI-2773.
Resolution
Upgrade to PLM version 2.2 or higher. There is no w/a for older versions for PLM.