Users cannot change passwords - Can't update idp user password 'null'
Original Publishing Date:
2022-10-19
Symptoms
Some users are unable to change their passwords in UX1.
They get an error:
Can't update idp user password 'null'

Password also cannot be reset from PCP by any user, even with admin level access.
Cause
IDP was enabled in the platform, however IDP migration task has failed or is still running:

It's also described in docs - https://docs.cloudblue.com/cbc/20.5/premium/content/Identity-Provider/Deploying-IDP.htm
Quote: Limitation: Changing user passwords during migration is not possible.
Resolution
The recommendation is to complete the IDP initialization, i.e. wait for the above task to complete.
Note: On large environments the task may take several days to complete.
Workaround: If there is no time to wait for the task to complete, IDP can be disabled to restore the functionality.