Office 365 - Task fails with error "Invalid MPN ID" despite the fact that MPN ID is correct
Original Publishing Date:
2020-01-22
Symptoms
Valid MPN ID is specified for the reseller in Odin Automation. However, provisioning fails with "Invalid MPN ID" error. There could be different sympthoms:
Case 1:
Task "Provisioning "Subscription" for APS application Office 365" fails with the error below:
APS Application Error:
500 Internal Server Error
[ApplicationUnknownError] Invalid MPN ID.
Body: {
"code": 500,
"message": "Invalid MPN ID",
"additionalNonlocalizableMessage": "",
"error": "ApplicationUnknownError",
"http_request": "POST /O365QBSUK/aps/subscriptions"
}
However, reseller has correct MPN ID specified and other Office 365 subscriptions of reseller are provisioned with no issues. From the sitelog, it can be seen that the cause of the issue is different:
2019-03-08 16:28:21,610 <9876> [ 13] DEBUG flow : Creating subscription: for offerId '8817b694-eea3-43f3-9b0b-4dcec5fb9f47'; quantity=1.
2019-03-08 16:28:22,891 <9876> [ 13] ERROR flow : The offer 8817b694-eea3-43f3-9b0b-4dcec5fb9f47 is not purchasable - Partner is not eligible to purchase item 8817B694-EEA3-43F3-9B0B-4DCEC5FB9F47..
Partner Exception:
Error Category: BadInput
Service Error Payload:
Error code: 2004
Error message: The offer 8817b694-eea3-43f3-9b0b-4dcec5fb9f47 is not purchasable - Partner is not eligible to purchase item 8817B694-EEA3-43F3-9B0B-4DCEC5FB9F47..
Office 365 version is below 19.2
Case 2:
Task "Delivering of event notification Resource limits changed" fails with the following error:
Invalid partnerId: 5211234
The following entry can be seen in sitelog:
2019-09-05 06:57:22,595 <7952> [ 5] INFO aps_endpoint: Need to update the partner Id of the subscription '5dbdb58a-***7e980f23' for offer '031c9e4***8fb1d2cc05': '5212347' -> '5211234'.
2019-09-05 06:57:22,610 <7952> [ 5] INFO flow : Try to set new quantity 3 for the subscription with id '5dbdb58***827e980f23' (csp subscription id '260606***b6d660be').
2019-09-05 06:57:29,392 <7952> [ 5] ERROR aps_endpoint: SubscriptionsController.OnSubscriptionChanged finished: ("16d0ba***ffdcfac48", {
"time": "2019-09-02T15:23:40Z",
"serial": "1021523",
"subscription": "f326cccd-15a6-4f00-a9ed-143448ff5742",
"id": null,
"source": {
"type": "http://parallels.com/aps/types/pa/subscription/1.0",
"id": "581c1c49-a596-4481-824d-d987b96b09e8"
},
"event": "http://parallels.com/aps/events/pa/subscription/limits/changed"
}) by exception Microsoft.Store.PartnerCenter.Exceptions.PartnerException: Invalid partnerId: 5212347
Office 365 version is 19.2
Cause
Case 1:
Error codes were changed on Microsoft side. Previously error code 2004 was received when incorrect MPN ID was specified, but currently it appears when there is an issue with offer availability.
Request #APSA-21015 has been submitted in order to improve error reporting of Office 365 application in this regards.
Case 2:
Office 365 application processes limits change incorrectly in case if MPN ID is modified. At first it tries to apply required limit for the subscription, then it tries to apply new MPN ID. However, attempt to change quantity fails because subscription have incorrect MPN ID of Microsoft side.
Aforementioned case is recognized as software-related issue #APSA-21466
Resolution
Case 1:
Upgrade your Office 365 applciation to version 19.2 where this issue is resolved. In order to determine the real cause of the issue on the current version, check sitelog of Office 365 application.
Case 2:
Contact your Technical Account Manager to clarify current status of the request.
As a workaround, set correct MPN ID directly in Microsoft Partner Center and restart the task.
Internal content
Link on internal Article