'Payment Method not Attached' error when trying to provision order on APS sandbox
Modified on: Fri, 17 Nov 2023 12:07 PMOriginal Publishing Date:
2020-01-22
2020-01-22
Symptoms
I'm testing application provisioning using Parallels Business Automation on my sandbox, when trying to complete order it hangs in status 'Payment Method not Attached
'.
Cause
PBA is a complex product that requires pre-configuration before usage in production.
Resolution
There are three ways to solve the problem:
- Make sure all prices are set to 0 in service plan
- Give credit memo to a customer which is used for testing:
[choose customer] > Documents > Add New Credit Memo
[choose customer] > General > Customer Class > Auto Apply Credits = Yes
- WARNING: should be done on APS sandboxes only, do not use in production:
Home > System > Settings > Terms > Credit Terms > [Default]
Set 'Put Account on Credit Hold' to 'Manually'
Set Credit Limit to a bigger value
If there is a failed order resubmit it, credit will be applied automatically to all further orders of the same customer.