Cannot switch to Billing in sandbox
Modified on: Fri, 17 Nov 2023 12:07 PM2020-01-22
Symptoms
I cannot switch to Billing in my sandbox, one of the following is happening when I click the 'Billing' button in Provider's panel:
- Page is being loaded for a long time
- An error about untrusted connection is shown
- A blank page is shown
Cause
Self-signed certificate is installed in Business Automation. Most browsers cannot handle accepting untrusted certificates in a frame
Resolution
Open
https://pba.YOUR_SANDBOX_NAME.apsdemo.org/
in browser. If you have newer configuration (lin-billing-new
) openhttps://pba.YOUR_SANDBOX_NAME.apsdemo.org:8443/
(notice the non-standard port number).Accept the self-signed certificate
A login screen appears. Do not enter any credentials into it
Open
http://YOUR_SANDBOX_NAME.apsdemo.org:8080
in browser (Operations Automation control panel) and log in.-
Billing
button should now be working.
For example, if your sandbox is a.developer.apsdemo.org
you should open https://pba.a.developer.apsdemo.org
and accept the certificate. Make sure you use https
and not http
, and specify port 8443 if you have a lin-billing-new
sandbox.
Then log in to http://a.developer.apsdemo.org
, log in and try the Billing
button.