[Failed order] Your customer account is currently under review. Check back in few days.
Original Publishing Date:
2023-08-23
Symptoms
Change order fails with below error:
The order provisioning failed.
The last error is "Task "Delivering event 'Resource limits changed' for APS application inhouse-products(https://inhouse-products:8081/rest)" (id = xxxxxx) is failed with error: "'500 Internal Server Error' received from 'POST https://inhouse-products:8081/rest/tenant/xxxxxxx-fd34-40ab-xxxx-c312f1ded9a7/onLimitChange': Operation 'LIMIT_CHANGE' failed. Fulfillment Request 'PR-XXXX-XXXX-XXX-XXX'. Reason: An error has occurred when changing base plan licenses: Your customer account is currently under review. Check back in few days. Your patience is appreciated during this time. Learn more at https://aka.ms/AA8lpeh.
Cause
The Error is coming from Microsoft as it seems the account is under the verification process, You can refer to this article by Microsoft to understand further regarding the process: https://learn.microsoft.com/en-us/partner-center/verification-responses
Resolution
1. Check the PR status on the Connect side:

2. In this case, The order needs to be canceled as it also failed on connect side.
3. Kindly contact Microsoft to rectify the issue with the customer's account. Place a new order once issue has been fixed by the Microsoft side.